User Tag List

Results 1 to 3 of 3

Thread: Hvac

  1. #1
    Member
    Join Date
    Sep 2015
    Posts
    68
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Hvac

    Has anyone had the blower motor failure happen in their Evo? The one outlined in the recall for no defrost visibility issues. My system is acting weird as in the air isn't coming out of the selected mode via the actuators when I select the different settings. I have tested the actuators via a Snap On Modius scan tool and the different actuators did in fact change when tested. I can also hear the blower motor making a lot of fan noise but it is like it isn't doing anything. Anyone else experience this?
    Map intake
    ams test pipe
    magnaflow cat back
    grimmspeed ebc
    Map uicp
    e85
    Proud fifth owner
    Kozmic sst tune

  2. #2
    Senior Member doom26464's Avatar
    Join Date
    Aug 2015
    Location
    Canada
    Posts
    1,466
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    I know this sounds obvious, but have you checked the cabin filter?
    12 GSR-GTX3576R
    Chet Rickerman tuned
    490whp 405wtq

    05 SRT-4- Project "turbo skittle"
    Needless torque tuned

  3. #3
    Member
    Join Date
    Sep 2015
    Posts
    68
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have replaced the cabin filter within the last year or so. Easy enough thing to check though.
    Map intake
    ams test pipe
    magnaflow cat back
    grimmspeed ebc
    Map uicp
    e85
    Proud fifth owner
    Kozmic sst tune

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •