User Tag List

Results 1 to 24 of 24

Thread: Purolator Explosion

  1. #1
    Senior Member rxreyn3's Avatar
    Join Date
    Aug 2015
    Posts
    224
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)

    Purolator Explosion

    *UPDATE* We're speculating this was not the filter but a faulty bypass valve in the oil pump.

    Has anyone ever seen a filter deform and blow the seal before? Dropped a gallon in a matter of seconds.



    Last edited by rxreyn3; 08-14-2016 at 09:53 AM.

  2. #2
    Evo X Harlot UT_EvoX's Avatar
    Join Date
    Aug 2015
    Posts
    2,559
    Mentioned
    251 Post(s)
    Tagged
    0 Thread(s)
    Well, I feel this is a confirmed issue with Purolator One (new design) filters. Same PL14459 part number we all know and love... but now they either have a design issue or a severe defect in this batch.

    As soon as we put the new intact filter pictured above on the car and revved it up to 2500 rpm, the filter deformed and dumped oil everywhere as the seal lost contact with the housing.

    Pieces of shit... very disappointed with Purolator. Avoid their new blue filters at all costs.

    Sent from my SM-G925P using Tapatalk
    350 WHP WW Flex Fuel 2014 Evo X MR | 600 WHP OB 2008 Evo X GSR

    Evo X Builder & Tuner since 2009 - Boosted Mitsubishis since 2005 | Buy fuel kits, flex fuel setups, or order an e-tune online: http://www.wtftuned.com/

    Follow us on Facebook: https://www.facebook.com/WTFTuned

  3. #3
    Senior Member
    Join Date
    Aug 2015
    Location
    Shenzhen
    Posts
    1,214
    Mentioned
    88 Post(s)
    Tagged
    0 Thread(s)
    Maybe there is a plug inside? jk
    2.3L Fully Built MR, 640whp on E100 EFR7670 T4 EWG. Struggling with local shops and customs.

  4. #4
    Global Mod of Things DKevoX's Avatar
    Join Date
    Aug 2015
    Posts
    1,868
    Mentioned
    98 Post(s)
    Tagged
    0 Thread(s)
    wow. how would oil pressures get that high? That's something weird going on.

  5. #5
    Senior Member Monster4's Avatar
    Join Date
    Jul 2016
    Location
    St. Louis, MO
    Posts
    168
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I just put one of these on my car this weekend. No leaking yet but I will report back.

  6. #6
    Global Mod of Things DKevoX's Avatar
    Join Date
    Aug 2015
    Posts
    1,868
    Mentioned
    98 Post(s)
    Tagged
    0 Thread(s)
    Why these filters just out of curiosity?

    I mean, there's oem, mobile one, K&N filters that are all easily available.

  7. #7
    Member
    Join Date
    Sep 2015
    Posts
    68
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by UT_EvoX View Post
    Well, I feel this is a confirmed issue with Purolator One (new design) filters. Same PL14459 part number we all know and love... but now they either have a design issue or a severe defect in this batch.

    As soon as we put the new intact filter pictured above on the car and revved it up to 2500 rpm, the filter deformed and dumped oil everywhere as the seal lost contact with the housing.

    Pieces of shit... very disappointed with Purolator. Avoid their new blue filters at all costs.

    Sent from my SM-G925P using Tapatalk
    If you weren't planning on it I would get them the info from the bottom of the filter they (Purolator) may be interested in getting the filter back as well. I don't know why they would change the burst capabilities of the filter if they didn't just have a bad batch.
    Map intake
    ams test pipe
    magnaflow cat back
    grimmspeed ebc
    Map uicp
    e85
    Proud fifth owner
    Kozmic sst tune

  8. #8
    Senior Member lew-e's Avatar
    Join Date
    Aug 2015
    Posts
    1,280
    Mentioned
    28 Post(s)
    Tagged
    0 Thread(s)
    Interesting. I was going to change my oil this weekend. Will probably go with the old Mobil 1 standby until this gets figured out


    Sent from my iPhone using Tapatalk

  9. #9
    Senior Member lew-e's Avatar
    Join Date
    Aug 2015
    Posts
    1,280
    Mentioned
    28 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by DKevoX View Post
    Why these filters just out of curiosity?

    I mean, there's oem, mobile one, K&N filters that are all easily available.
    Wasn't there a big thread about this a few months ago? There was a big to-do about a thread on evom and based on price, availability, and quality, this filter was the all around "best option"


    Sent from my iPhone using Tapatalk

  10. #10
    Senior Member rxreyn3's Avatar
    Join Date
    Aug 2015
    Posts
    224
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by DKevoX View Post
    wow. how would oil pressures get that high? That's something weird going on.
    The pressure is pretty high on cold start e.g. well over 120 psi at our elevation. We blew two purolators pretty quickly before switching to the wix. As others are not experiencing problems with the "new" design, perhaps it is a bad batch. I'll be reaching out to purolator for support. Just glad this kid didn't blow his engine.

  11. #11
    Evo X Harlot UT_EvoX's Avatar
    Join Date
    Aug 2015
    Posts
    2,559
    Mentioned
    251 Post(s)
    Tagged
    0 Thread(s)
    Oil pressure is that high on cold start anywhere. And this happened during summer temperatures. I wonder how bad it would be in cold weather.

    I have a feeling the bypass valves on these filters aren't working and therfore super viscous oil is unable to flow past the filter media and crazy pressure is building up at the filter.

    Or it's a design flaw with the case.

    Sent from my SM-G925P using Tapatalk
    350 WHP WW Flex Fuel 2014 Evo X MR | 600 WHP OB 2008 Evo X GSR

    Evo X Builder & Tuner since 2009 - Boosted Mitsubishis since 2005 | Buy fuel kits, flex fuel setups, or order an e-tune online: http://www.wtftuned.com/

    Follow us on Facebook: https://www.facebook.com/WTFTuned

  12. #12
    Senior Member
    Join Date
    Aug 2015
    Location
    Knoxville
    Posts
    112
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I just used one of these this last weekend as well. I got it from Amazon and thought it was weird that they were blue now instead of yellow with grippy texture. There was an old thread on evoM testing different filters and the pure 1 filters came out on top. With this design change it sounds like I need to jump ship. I've had no leaks so far, but seeing this worries me.

  13. #13
    Evo X Harlot UT_EvoX's Avatar
    Join Date
    Aug 2015
    Posts
    2,559
    Mentioned
    251 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ZLAYER View Post
    I just used one of these this last weekend as well. I got it from Amazon and thought it was weird that they were blue now instead of yellow with grippy texture. There was an old thread on evoM testing different filters and the pure 1 filters came out on top. With this design change it sounds like I need to jump ship. I've had no leaks so far, but seeing this worries me.
    Personally I'd be very vigilant about it and it may be worth swapping just to be safe.
    350 WHP WW Flex Fuel 2014 Evo X MR | 600 WHP OB 2008 Evo X GSR

    Evo X Builder & Tuner since 2009 - Boosted Mitsubishis since 2005 | Buy fuel kits, flex fuel setups, or order an e-tune online: http://www.wtftuned.com/

    Follow us on Facebook: https://www.facebook.com/WTFTuned

  14. #14
    Senior Member doom26464's Avatar
    Join Date
    Aug 2015
    Location
    Canada
    Posts
    1,466
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    bad seal, either faulty batch or got damaged some how.

    As some one who has probably changed a million filter in his life and does it day in and day out It has happened a few times with some off brand filters and a few frams with poor seals. Usually it is they don't leak a drop or when they leak it is drop all the oil in a matter of seconds lol. Proper torquing is key too.

    I prefer wix for my stuff and all my customers vehicles or OEM. Never have a problem with them.
    12 GSR-GTX3576R
    Chet Rickerman tuned
    490whp 405wtq

    05 SRT-4- Project "turbo skittle"
    Needless torque tuned

  15. #15
    Evo X Harlot UT_EvoX's Avatar
    Join Date
    Aug 2015
    Posts
    2,559
    Mentioned
    251 Post(s)
    Tagged
    0 Thread(s)
    How exactly would a bad seal cause it to balloon out like that? Read the whole thread. We installed a virgin filter and it did the same. exact. thing.
    350 WHP WW Flex Fuel 2014 Evo X MR | 600 WHP OB 2008 Evo X GSR

    Evo X Builder & Tuner since 2009 - Boosted Mitsubishis since 2005 | Buy fuel kits, flex fuel setups, or order an e-tune online: http://www.wtftuned.com/

    Follow us on Facebook: https://www.facebook.com/WTFTuned

  16. #16
    Senior Member doom26464's Avatar
    Join Date
    Aug 2015
    Location
    Canada
    Posts
    1,466
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    I miss read sorry.


    Bypass valve being faulty is the more likely culprit then.
    12 GSR-GTX3576R
    Chet Rickerman tuned
    490whp 405wtq

    05 SRT-4- Project "turbo skittle"
    Needless torque tuned

  17. #17
    Evo X Harlot UT_EvoX's Avatar
    Join Date
    Aug 2015
    Posts
    2,559
    Mentioned
    251 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by doom26464 View Post
    I miss read sorry.


    Bypass valve being faulty is the more likely culprit then.
    Must be... sucks as Purolator used to be very good, but it's time to move on I guess.

    We've contacted Purolator corporate but they're just blowing smoke up our asses TBH.
    350 WHP WW Flex Fuel 2014 Evo X MR | 600 WHP OB 2008 Evo X GSR

    Evo X Builder & Tuner since 2009 - Boosted Mitsubishis since 2005 | Buy fuel kits, flex fuel setups, or order an e-tune online: http://www.wtftuned.com/

    Follow us on Facebook: https://www.facebook.com/WTFTuned

  18. #18
    Evo X Harlot UT_EvoX's Avatar
    Join Date
    Aug 2015
    Posts
    2,559
    Mentioned
    251 Post(s)
    Tagged
    0 Thread(s)
    Update... doesn't look like it was anything related to the oil filter per se. With a Wix filter already slightly bulging, we conclude the car must have a stuck pressure relief valve (located on the oil pump assembly).

    I've not seen that on a 4B11T yet, but I do see another fellow on EvoXForums who did have it happen to him. >150 PSI oil pressure on cold idle. http://www.evoxforums.com/forums/sho...d.php?t=319921
    350 WHP WW Flex Fuel 2014 Evo X MR | 600 WHP OB 2008 Evo X GSR

    Evo X Builder & Tuner since 2009 - Boosted Mitsubishis since 2005 | Buy fuel kits, flex fuel setups, or order an e-tune online: http://www.wtftuned.com/

    Follow us on Facebook: https://www.facebook.com/WTFTuned

  19. #19
    Senior Member
    Join Date
    Aug 2015
    Location
    Knoxville
    Posts
    112
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Sheesh, good to know!

  20. #20
    Senior Member Hiboost's Avatar
    Join Date
    Aug 2015
    Posts
    143
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    So it's just this particular car and not the Purolator filters then? I've heard of super high pressure building in cars that had recently swapped their engine after a failure where something jammed the pressure relief valve in the oil pump assembly. If you can edit the original post with the update I think that would be wise, I almost swore off using them but luckily read the thread til the end.
    Chris Wirth
    Build: HiboostTuning.com
    2011 Octane Blue Evo X MR
    Best 1/4 Mile ET & Speed: 11.677 @ 119.06
    STM Mustang Dyno: 390 whp / 360 wtq

    2017 Global Time Attack - Limited AWD Class
    2nd - Road Atlanta

    2017 CSCS Time Attack - Street AWD Class
    1st - Mosport DDT 1:38.391 (Record)
    1st - TMP 1:17.644 (Record)
    1st - TMP Reverse 1:23.944 (Record)
    1st - Shannonville 1:59.748 (Record)

  21. #21
    Junior Member Gman15975's Avatar
    Join Date
    Aug 2015
    Location
    Erie
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm surprised you would use a purolator, after people on BITOG found multiple examples with torn media and didn't acknowledge the issue.

  22. #22
    Senior Member ak47's Avatar
    Join Date
    Aug 2015
    Posts
    1,842
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    I used Royal Purple filter but not the oil.

  23. #23
    Evo X Harlot UT_EvoX's Avatar
    Join Date
    Aug 2015
    Posts
    2,559
    Mentioned
    251 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Hiboost View Post
    So it's just this particular car and not the Purolator filters then? I've heard of super high pressure building in cars that had recently swapped their engine after a failure where something jammed the pressure relief valve in the oil pump assembly. If you can edit the original post with the update I think that would be wise, I almost swore off using them but luckily read the thread til the end.
    I didn't write the OP.
    350 WHP WW Flex Fuel 2014 Evo X MR | 600 WHP OB 2008 Evo X GSR

    Evo X Builder & Tuner since 2009 - Boosted Mitsubishis since 2005 | Buy fuel kits, flex fuel setups, or order an e-tune online: http://www.wtftuned.com/

    Follow us on Facebook: https://www.facebook.com/WTFTuned

  24. #24
    Senior Member rxreyn3's Avatar
    Join Date
    Aug 2015
    Posts
    224
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    We're speculating that this was not the filter but instead a faulty oil pump bypass valve. With that said, the replacement WIX filter clearly has higher tolerances than the Purolator, and in this case, is saving an engine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •